diff options
author | Simon McVittie <smcv@celebrin.pseudorandom.co.uk> | 2006-11-14 14:26:14 +0000 |
---|---|---|
committer | Simon McVittie <smcv@celebrin.pseudorandom.co.uk> | 2006-11-14 14:26:14 +0000 |
commit | 1a4b9502f1d06e94fd5f90bfd85cf4d47b88c1fd (patch) | |
tree | 703c33f594fd01b7581bd7138a5a79df321e45a1 /setup.py | |
parent | 4ce650d5c4ca5807c8eb4bc6f8074ff6eddab359 (diff) | |
download | dbus-python-1a4b9502f1d06e94fd5f90bfd85cf4d47b88c1fd.tar.gz |
setup.py: Import CFLAGS from environment (used by development Makefile for warning control)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 7 |
1 files changed, 7 insertions, 0 deletions
@@ -132,6 +132,11 @@ two apps to communicate directly (without going through the message bus daemon). Currently the communicating applications are on one computer, but TCP/IP option is available and remote support planned.''' +extra_ext_args = {} + +if 'CFLAGS' in os.environ: + extra_ext_args['extra_compile_args'] = os.environ['CFLAGS'].split() + setup( name='dbus-python', version='0.71', @@ -160,11 +165,13 @@ setup( include_dirs=dbus_includes, library_dirs=dbus_libs, libraries=["dbus-1"], + **extra_ext_args ), Extension("_dbus_glib_bindings", ["_dbus_glib_bindings/module.c"], include_dirs=dbus_glib_includes, library_dirs=dbus_glib_libs, libraries=["dbus-glib-1", "dbus-1", "glib-2.0"], + **extra_ext_args ), ], cmdclass={'clean': full_clean, 'check': dbus_python_check} |