summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@remedyz.boston.redhat.com>2006-07-27 13:57:56 -0400
committerJohn Palmieri <johnp@remedyz.boston.redhat.com>2006-07-27 13:57:56 -0400
commiteae6cd4e466d9d6dd477cf0bb5ef2b183f4c69f9 (patch)
tree4953f9bf478980d4cb3d4030b131a50922bc1487 /setup.py
parentf5258f571de77b18354e17073d44f316d1e0af1b (diff)
downloaddbus-python-eae6cd4e466d9d6dd477cf0bb5ef2b183f4c69f9.tar.gz
* setup.py: read the stdout pipe before stderr
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 59a2e27..0d0a90d 100644
--- a/setup.py
+++ b/setup.py
@@ -56,7 +56,8 @@ dbus_glib_includes.extend([ x.replace("-I", "") for x in output.split() ])
if os.path.exists(".git"):
pipe = ""
pipe = os.popen3("git-log --stat")
-
+
+ output = pipe[1].read().strip()
error = pipe[2].read().strip()
if error:
@@ -64,14 +65,13 @@ if os.path.exists(".git"):
p.close()
pipe = os.popen3("git-log")
+ output = pipe[1].read().strip()
error = pipe[2].read().strip()
if error:
print "ERROR: running git-log (%s)" % (error)
raise SystemExit
- output = pipe[1].read().strip()
-
for p in pipe:
p.close()