summaryrefslogtreecommitdiff
path: root/include_server/setup.py
diff options
context:
space:
mode:
authorclutton <clutton@zoho.com>2016-04-14 22:33:21 +0300
committerclutton <clutton@zoho.com>2016-04-14 22:33:21 +0300
commit7dfb29db81c7a07bfaefd148258c6a897e8bac1b (patch)
treefe4ea88adc063545bd34b0dbd124fd1bc769b44c /include_server/setup.py
parent50e5b666d85c92a963ed6c1d4150683e87b8b9a5 (diff)
downloaddistcc-git-python3.tar.gz
include_server python(3) readypython3
Diffstat (limited to 'include_server/setup.py')
-rwxr-xr-xinclude_server/setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/include_server/setup.py b/include_server/setup.py
index 03085b0..1cbc9f6 100755
--- a/include_server/setup.py
+++ b/include_server/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python2.4
+#!/usr/bin/env python3
# Copyright 2007 Google Inc.
#
@@ -58,7 +58,7 @@ def GetIncludes(flags):
In the doctests below, note that a single quoted backslash takes four
backslashes to represent if it is inside a single quoted string inside this
present triple-quoted string.
-
+
>>> GetIncludes('-I x -X -I"y" -Y')
['x', 'y']
>>> GetIncludes('-Ix -Dfoo -Iy')
@@ -103,7 +103,7 @@ cpp_flags_env = os.getenv('CPPFLAGS', '')
if not cpp_flags_env:
# Don't quit; perhaps the user is asking for help using '--help'.
# CPPFLAGS checking.
- print >> sys.stderr, 'setup.py: CPPFLAGS must be defined.'
+ print('setup.py: CPPFLAGS must be defined.', sys.stderr)
# CPPFLAGS is passed to us as it's used in the Makefile: a string that the shell
# will interpret. GetInclude uses shlex to do the same kind of interpretation
# in order to identify the include directory options.
@@ -112,7 +112,7 @@ cpp_flags_includes = GetIncludes(cpp_flags_env)
# SRCDIR checking.
if not os.getenv('SRCDIR'):
# Don't quit; perhaps the user is asking for help using '--help'.
- print >> sys.stderr, 'setup.py: SRCDIR must be defined.'
+ print('setup.py: SRCDIR must be defined.', sys.stderr)
srcdir = 'UNDEFINED'
srcdir_include_server = 'UNDEFINED'
else: