summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Scherer <stefan.scherer@docker.com>2021-10-14 19:25:22 +0200
committerGitHub <noreply@github.com>2021-10-14 19:25:22 +0200
commita48a5a9647761406d66e8271f19fab7fa0c5f582 (patch)
tree391594baa59a9662794de1c363e17ba06f887aa9 /setup.py
parentac5f6ef93aa392090b5e6bc3c8b1112cf0c8981d (diff)
parent4bb99311e2911406dde543117438782a9524feea (diff)
downloaddocker-py-master.tar.gz
Merge pull request #2898 from hugovk/add-3.10master
Add support for Python 3.10
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a966fea..db2d6eb 100644
--- a/setup.py
+++ b/setup.py
@@ -29,7 +29,7 @@ extras_require = {
'tls': ['pyOpenSSL>=17.5.0', 'cryptography>=3.4.7', 'idna>=2.0.0'],
# Only required when connecting using the ssh:// protocol
- 'ssh': ['paramiko>=2.4.2'],
+ 'ssh': ['paramiko>=2.4.3'],
}
@@ -75,6 +75,7 @@ setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Topic :: Software Development',
'Topic :: Utilities',
'License :: OSI Approved :: Apache Software License',