diff options
author | Ulysses Souza <ulyssessouza@gmail.com> | 2021-03-10 20:43:37 -0300 |
---|---|---|
committer | Ulysses Souza <ulyssessouza@gmail.com> | 2021-03-22 10:18:23 -0300 |
commit | c8fba210a222d4f7fde90da8f48db1e7faa637ec (patch) | |
tree | c895f87ae9f514e0a47a39326d2a004ffd17275b /setup.py | |
parent | 31775a1532a66cf8a4c183a99bb5c73623147295 (diff) | |
download | docker-py-set-minimal-python-to-3_6.tar.gz |
Remove support to pre python 3.6set-minimal-python-to-3_6
Signed-off-by: Ulysses Souza <ulyssessouza@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 1 insertions, 11 deletions
@@ -11,18 +11,11 @@ ROOT_DIR = os.path.dirname(__file__) SOURCE_DIR = os.path.join(ROOT_DIR) requirements = [ - 'six >= 1.4.0', 'websocket-client >= 0.32.0', 'requests >= 2.14.2, != 2.18.0', ] extras_require = { - ':python_version < "3.5"': 'backports.ssl_match_hostname >= 3.5', - # While not imported explicitly, the ipaddress module is required for - # ssl_match_hostname to verify hosts match with certificates via - # ServerAltname: https://pypi.python.org/pypi/backports.ssl_match_hostname - ':python_version < "3.3"': 'ipaddress >= 1.0.16', - # win32 APIs if on Windows (required for npipe support) ':sys_platform == "win32"': 'pywin32==227', @@ -69,7 +62,7 @@ setup( install_requires=requirements, tests_require=test_requirements, extras_require=extras_require, - python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*', + python_requires='>=3.6', zip_safe=False, test_suite='tests', classifiers=[ @@ -78,10 +71,7 @@ setup( 'Intended Audience :: Developers', 'Operating System :: OS Independent', 'Programming Language :: Python', - 'Programming Language :: Python :: 2', - 'Programming Language :: Python :: 2.7', 'Programming Language :: Python :: 3', - 'Programming Language :: Python :: 3.5', 'Programming Language :: Python :: 3.6', 'Programming Language :: Python :: 3.7', 'Programming Language :: Python :: 3.8', |