diff options
author | Milas Bowman <milas.bowman@docker.com> | 2022-07-28 08:32:00 -0400 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-07-28 08:32:00 -0400 |
commit | be942f83902fbd02e05270c39b6917880939c165 (patch) | |
tree | bf7b81f3a38dc94386abe63aef8bb4ce4f8d22bb /setup.py | |
parent | bf026265e0adfd862373a601ed99e4f3ac8b3bd0 (diff) | |
download | docker-py-be942f83902fbd02e05270c39b6917880939c165.tar.gz |
deps: upgrade & remove unnecessary dependencies (#3014)
The `requirements.txt` and `setup.py` had a lot of extra transitive
dependencies to try and address various SSL shortcomings from the
Python ecosystem.
Thankfully, between modern Python versions (3.6+) and corresponding
`requests` versions (2.26+), this is all unnecessary now!
As a result, a bunch of transitive dependencies have been removed
from `requirements.txt`, the minimum version of `requests` increased,
and the `tls` extra made into a no-op.
Signed-off-by: Milas Bowman <milas.bowman@docker.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 19 |
1 files changed, 7 insertions, 12 deletions
@@ -10,28 +10,23 @@ ROOT_DIR = os.path.dirname(__file__) SOURCE_DIR = os.path.join(ROOT_DIR) requirements = [ - 'packaging', + 'packaging >= 14.0', + 'requests >= 2.26.0', + 'urllib3 >= 1.26.0', 'websocket-client >= 0.32.0', - 'requests >= 2.14.2, != 2.18.0', ] extras_require = { # win32 APIs if on Windows (required for npipe support) ':sys_platform == "win32"': 'pywin32>=304', - # If using docker-py over TLS, highly recommend this option is - # pip-installed or pinned. - - # TODO: if pip installing both "requests" and "requests[security]", the - # extra package from the "security" option are not installed (see - # https://github.com/pypa/pip/issues/4391). Once that's fixed, instead of - # installing the extra dependencies, install the following instead: - # 'requests[security] >= 2.5.2, != 2.11.0, != 2.12.2' - 'tls': ['pyOpenSSL>=17.5.0', 'cryptography>=3.4.7', 'idna>=2.0.0'], + # This is now a no-op, as similarly the requests[security] extra is + # a no-op as of requests 2.26.0, this is always available/by default now + # see https://github.com/psf/requests/pull/5867 + 'tls': [], # Only required when connecting using the ssh:// protocol 'ssh': ['paramiko>=2.4.3'], - } version = None |