diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 12 insertions, 0 deletions
@@ -33,10 +33,20 @@ with open('./test-requirements.txt') as test_reqs_txt: test_requirements = [line for line in test_reqs_txt] +long_description = '' +try: + with open('./README.rst') as readme_rst: + long_description = readme_rst.read() +except IOError: + # README.rst is only generated on release. Its absence should not prevent + # setup.py from working properly. + pass + setup( name="docker-py", version=version, description="Python client for Docker.", + long_description=long_description, url='https://github.com/docker/docker-py/', packages=[ 'docker', 'docker.api', 'docker.auth', 'docker.transport', @@ -64,4 +74,6 @@ setup( 'Topic :: Utilities', 'License :: OSI Approved :: Apache Software License', ], + maintainer='Joffrey F', + maintainer_email='joffrey@docker.com', ) |