diff options
author | Pino Toscano <ptoscano@redhat.com> | 2022-06-25 06:30:45 +0200 |
---|---|---|
committer | Pino Toscano <ptoscano@redhat.com> | 2022-06-25 06:38:30 +0200 |
commit | ba4db43f636d701411b10b44fbb77f02393b4e98 (patch) | |
tree | 7967f83335e659e600c00b16222cb516efd557b0 /setup.py | |
parent | b34fbaf405c61935efbd0d3e9b3a134f26097ea7 (diff) | |
download | libvirt-python-ba4db43f636d701411b10b44fbb77f02393b4e98.tar.gz |
setup: make 'clean' command compatible again with distutilsv8.5.0
After the switch of 'my_clean' to a simple Command, the 'clean' command
has no more bits for options, resulting in distutils (either external
or embedded in setuptools) complaining about it:
distutils.errors.DistutilsClassError: command class <class '__main__.my_clean'> must provide 'user_options' attribute (a list of tuples)
To overcome that, provide all the standard bits from options, i.e. the
'user_options' list, and the 'initialize_options' & 'finalize_options'
methods. In addition, add a dummy 'all' option, as distutils wants it:
error: error in [...]/.pydistutils.cfg: command 'my_clean' has no such option 'all'
Fixes commit a965c91c6fa1275613edbbef75c0422574eb9ff2
Signed-off-by: Pino Toscano <ptoscano@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 10 |
1 files changed, 10 insertions, 0 deletions
@@ -313,6 +313,16 @@ class my_test(Command): subprocess.check_call([pytest]) class my_clean(Command): + user_options = [ + ('all', None, 'unused, compatibility with distutils') + ] + + def initialize_options(self): + self.all = False + + def finalize_options(self): + pass + def run(self): if os.path.exists("build"): shutil.rmtree("build", ignore_errors=True) |