summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2023-05-13 21:00:08 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2023-05-13 21:04:15 +0200
commit551a770a3d5cd801c87946bdfe74f9a6e9a4524e (patch)
treeea5b3a818a919d19e292f3de66d5535b2d0a3ec1 /setup.py
parentb98f5ee75ec5ef9b5dbce17645217ea57a793176 (diff)
downloadpygobject-master.tar.gz
Require glib 2.64 and g-i 1.64HEADmaster
Since we now target Python 3.8+, looking at Debian and Ubuntu releases we have 1/2.64 in Ubuntu 20.04 and 1/2.66 in Debian bullseye. Go with the older one of the two.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 709b5605..4cd79ed9 100755
--- a/setup.py
+++ b/setup.py
@@ -37,8 +37,8 @@ from distutils.spawn import find_executable
PYGOBJECT_VERSION = "3.45.0"
-GLIB_VERSION_REQUIRED = "2.56.0"
-GI_VERSION_REQUIRED = "1.60.0"
+GLIB_VERSION_REQUIRED = "2.64.0"
+GI_VERSION_REQUIRED = "1.64.0"
PYCAIRO_VERSION_REQUIRED = "1.16.0"
LIBFFI_VERSION_REQUIRED = "3.0"