diff options
author | Ned Batchelder <ned@nedbatchelder.com> | 2021-05-01 18:26:17 -0400 |
---|---|---|
committer | Ned Batchelder <ned@nedbatchelder.com> | 2021-05-02 07:38:19 -0400 |
commit | 14449eedfa140b5a55896b9e064d3b52af9670f5 (patch) | |
tree | c5b8ac9517066de8cacfe577c945f2ccfa26ab20 /setup.py | |
parent | ddf5ba8cfcfe7d133ddbf888cc6e3af79863c712 (diff) | |
download | python-coveragepy-git-14449eedfa140b5a55896b9e064d3b52af9670f5.tar.gz |
refactor: pyupgrade --py36-plus *.py
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -113,7 +113,7 @@ setup_args = dict( # We need to get HTML assets from our htmlfiles directory. zip_safe=False, - author='Ned Batchelder and {} others'.format(num_others), + author=f'Ned Batchelder and {num_others} others', author_email='ned@nedbatchelder.com', description=doc, long_description=long_description, @@ -218,8 +218,8 @@ def main(): setup(**setup_args) except BuildFailed as exc: msg = "Couldn't install with extension module, trying without it..." - exc_msg = "%s: %s" % (exc.__class__.__name__, exc.cause) - print("**\n** %s\n** %s\n**" % (msg, exc_msg)) + exc_msg = f"{exc.__class__.__name__}: {exc.cause}" + print(f"**\n** {msg}\n** {exc_msg}\n**") del setup_args['ext_modules'] setup(**setup_args) |