summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2021-09-18 16:55:06 +0100
committerJelmer Vernooij <jelmer@jelmer.uk>2021-09-18 16:55:06 +0100
commit90cc92891309e192f6c6ba2665badac12619a1ed (patch)
treec6e3e5720f914749799946f40bca3a39b0729f02 /setup.py
parent088bc0459e50bbcb948f3317772825859347b014 (diff)
parent6ed4b196e21974c6bac4323522cd086794618068 (diff)
downloadpython-fastimport-git-upstream.tar.gz
Import upstream version 0.9.14upstream/0.9.14upstream
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index c67cb1a..353f0fd 100755
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,7 @@
#!/usr/bin/env python
-from distutils.core import setup
+from setuptools import setup
-version = "0.9.8"
+version = "0.9.14"
setup(name="fastimport",
description="VCS fastimport/fastexport parser",
@@ -13,6 +13,8 @@ setup(name="fastimport",
license="GNU GPL v2 or later",
url="https://github.com/jelmer/python-fastimport",
packages=['fastimport', 'fastimport.tests', 'fastimport.processors'],
+ test_suite="fastimport.tests.test_suite",
+ python_requires=">=3.5",
scripts=[
'bin/fast-import-query',
'bin/fast-import-filter',
@@ -20,10 +22,12 @@ setup(name="fastimport",
],
classifiers=[
'Development Status :: 4 - Beta',
- 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.4',
+ 'License :: OSI Approved :: GNU General Public License v2 '
+ 'or later (GPLv2+)',
'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Operating System :: POSIX',