diff options
author | Stefan Kögl <stefan@skoegl.net> | 2014-03-09 14:44:49 +0100 |
---|---|---|
committer | Stefan Kögl <stefan@skoegl.net> | 2014-03-09 14:45:25 +0100 |
commit | 32f6363108903e6dbc480d424b148cd256782911 (patch) | |
tree | 6ee9f1206a5e557005986d62b10c408d1a7c15f8 /setup.py | |
parent | 6e2016548fbcdaf898ff117a10f014a721c4a305 (diff) | |
download | python-json-pointer-32f6363108903e6dbc480d424b148cd256782911.tar.gz |
add trove classifiers (fixes #6)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 21 |
1 files changed, 21 insertions, 0 deletions
@@ -25,6 +25,26 @@ DESCRIPTION = docstrings[0] # Extract name and e-mail ("Firstname Lastname <mail@example.org>") AUTHOR, EMAIL = re.match(r'(.*) <(.*)>', AUTHOR_EMAIL).groups() +CLASSIFIERS = [ + 'Development Status :: 5 - Production/Stable', + 'Environment :: Console', + 'Intended Audience :: Developers', + 'License :: OSI Approved :: BSD License', + 'Operating System :: OS Independent', + 'Programming Language :: Python', + 'Programming Language :: Python :: 2', + 'Programming Language :: Python :: 2.6', + 'Programming Language :: Python :: 2.7', + 'Programming Language :: Python :: 3', + 'Programming Language :: Python :: 3.2', + 'Programming Language :: Python :: 3.3', + 'Programming Language :: Python :: 3.4', + 'Programming Language :: Python :: Implementation :: CPython', + 'Programming Language :: Python :: Implementation :: PyPy', + 'Topic :: Software Development :: Libraries', + 'Topic :: Utilities', +] + setup(name=PACKAGE, version=VERSION, description=DESCRIPTION, @@ -38,4 +58,5 @@ setup(name=PACKAGE, 'console_scripts': [ 'jsonpointer = jsonpointer:main', ]}, + classifiers=CLASSIFIERS, ) |