diff options
author | Stefan Kögl <stefan@skoegl.net> | 2014-10-25 15:24:44 +0200 |
---|---|---|
committer | Stefan Kögl <stefan@skoegl.net> | 2014-10-25 15:24:44 +0200 |
commit | 7c4a5fcf15a4e577067a67364fa379ddb3acb555 (patch) | |
tree | 17610595c5d597753f7b5489a4bc3a0abfdaaea1 /setup.py | |
parent | 88a966bb22e1d5f9156662e21f8f67f8f6a50ba7 (diff) | |
download | python-json-pointer-7c4a5fcf15a4e577067a67364fa379ddb3acb555.tar.gz |
Convert readme from markdown to rst for PyPI
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 9 insertions, 0 deletions
@@ -26,6 +26,14 @@ DESCRIPTION = docstrings[0] # Extract name and e-mail ("Firstname Lastname <mail@example.org>") AUTHOR, EMAIL = re.match(r'(.*) <(.*)>', AUTHOR_EMAIL).groups() +try: + from pypandoc import convert + read_md = lambda f: convert(f, 'rst') +except ImportError: + print('warning: pypandoc module not found, could not convert ' + 'Markdown to RST') + read_md = lambda f: open(f, 'r').read() + CLASSIFIERS = [ 'Development Status :: 5 - Production/Stable', 'Environment :: Console', @@ -49,6 +57,7 @@ CLASSIFIERS = [ setup(name=PACKAGE, version=VERSION, description=DESCRIPTION, + long_description=read_md('README.md'), author=AUTHOR, author_email=EMAIL, license=LICENSE, |