summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2015-02-14 10:58:50 +0100
committerStefan Behnel <stefan_ml@behnel.de>2015-02-14 10:58:50 +0100
commit420f7eabba66a010f44a9b1657aea8ddc6dc5249 (patch)
treef9501aa61ed6fce7118f1e88787f00adbf83d26d /setup.py
parent7e440f7563b46ac1952b91244ca346462b6fee0a (diff)
downloadpython-lxml-420f7eabba66a010f44a9b1657aea8ddc6dc5249.tar.gz
remove dead code from build scripts
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b2438fc2..1121f526 100644
--- a/setup.py
+++ b/setup.py
@@ -27,9 +27,9 @@ STATIC_CFLAGS = []
STATIC_BINARIES = []
# create lxml-version.h file
-svn_version = versioninfo.svn_version()
-versioninfo.create_version_h(svn_version)
-print("Building lxml version %s." % svn_version)
+versioninfo.create_version_h()
+lxml_version = versioninfo.version()
+print("Building lxml version %s." % lxml_version)
OPTION_RUN_TESTS = setupinfo.has_option('run-tests')
@@ -173,13 +173,13 @@ def setup_extra_options():
setup(
name = "lxml",
- version = versioninfo.version(),
+ version = lxml_version,
author="lxml dev team",
author_email="lxml-dev@lxml.de",
maintainer="lxml dev team",
maintainer_email="lxml-dev@lxml.de",
url="http://lxml.de/",
- download_url="http://pypi.python.org/packages/source/l/lxml/lxml-%s.tar.gz" % versioninfo.version(),
+ download_url="http://pypi.python.org/packages/source/l/lxml/lxml-%s.tar.gz" % lxml_version,
bugtrack_url="https://bugs.launchpad.net/lxml",
description="Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API.",