summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2021-11-01 11:29:23 +0100
committerStefan Behnel <stefan_ml@behnel.de>2021-11-02 11:56:41 +0100
commit54b4074b5935f4743299a2a73cfa877618a0a220 (patch)
treec75071b112fcc32399d47817e7821b4e43e66364 /setup.py
parentf8924b87ea6db10d4b6c2a6c78aa0e72ca72f578 (diff)
downloadpython-lxml-54b4074b5935f4743299a2a73cfa877618a0a220.tar.gz
Add wheel building workflow for Github Actions.lxml-4.6.4-pre
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2dcaf4f6..04b71462 100644
--- a/setup.py
+++ b/setup.py
@@ -255,4 +255,7 @@ an appropriate version of Cython installed.
if OPTION_RUN_TESTS:
print("Running tests.")
import test
- sys.exit( test.main(sys.argv[:1]) )
+ try:
+ sys.exit( test.main(sys.argv[:1]) )
+ except ImportError:
+ pass # we assume that the binaries were not built with this setup.py run