summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarc Abramowitz <marc@marc-abramowitz.com>2015-03-05 08:01:07 -0800
committerMarc Abramowitz <marc@marc-abramowitz.com>2015-03-05 08:05:27 -0800
commit657809736528e2018e3bf1dd3b67d075752e9c18 (patch)
tree22d85d31b1680978dc624fa7f9f0314f71671346 /setup.py
parented6af05991ca39910c575e7177a8389244a2cc4f (diff)
downloadpython-lxml-657809736528e2018e3bf1dd3b67d075752e9c18.tar.gz
Remove bugtrack_url because it causes warning
I don't think bugtrack_url has any effect on PyPI (you have to set the bugtrack_url in the PyPI UI I believe) and this causes a `Unknown distribution option: 'bugtrack_url'` warning to be emitted when installing or building a wheel. $ pip wheel lxml Collecting lxml Using cached lxml-3.4.2.tar.gz /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'bugtrack_url' warnings.warn(msg)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1121f526..82b849ab 100644
--- a/setup.py
+++ b/setup.py
@@ -180,7 +180,11 @@ setup(
maintainer_email="lxml-dev@lxml.de",
url="http://lxml.de/",
download_url="http://pypi.python.org/packages/source/l/lxml/lxml-%s.tar.gz" % lxml_version,
- bugtrack_url="https://bugs.launchpad.net/lxml",
+
+ # Commented out because this causes distutils to emit warnings
+ # `Unknown distribution option: 'bugtrack_url'`
+ # which distract folks from real causes of problems when troubleshooting
+ # bugtrack_url="https://bugs.launchpad.net/lxml",
description="Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API.",