summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2017-08-17 08:24:06 +0200
committerStefan Behnel <stefan_ml@behnel.de>2017-08-17 08:24:06 +0200
commita0599527c0328b715c9087c6716485cb1efb4ba4 (patch)
tree2e46ec94c79eb5216320714d84005fde396dda10 /setup.py
parent385cddcbee90802c30f4c542b45c70c8cbd42fa1 (diff)
downloadpython-lxml-a0599527c0328b715c9087c6716485cb1efb4ba4.tar.gz
Try to ignore externally installed lxml packages when building, to prevent accidentally picking up their cimport/include files.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7fe3aeec..8c0ded82 100644
--- a/setup.py
+++ b/setup.py
@@ -2,6 +2,7 @@ import os
import re
import sys
import fnmatch
+import os.path
# for command line options and supported environment variables, please
# see the end of 'setupinfo.py'
@@ -15,6 +16,9 @@ try:
except ImportError:
from distutils.core import setup
+# make sure Cython finds include files in the project directory and not outside
+sys.path.insert(0, os.path.join(os.path.dirname(__file__), 'src'))
+
import versioninfo
import setupinfo