summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2017-08-11 14:33:51 +0200
committerStefan Behnel <stefan_ml@behnel.de>2017-08-11 14:33:51 +0200
commitccc44405d538546314891eae433cb8037ee09c29 (patch)
tree066196410153d0ca8a9e27088b99c9220e08698d /setup.py
parent82675f9d03a180471056e9fd629e0f13ce4085a1 (diff)
downloadpython-lxml-ccc44405d538546314891eae433cb8037ee09c29.tar.gz
Properly integrate the compilation of _elementpath.py and some lxml.html modules into the build process and exclude it in PyPy.
Also finally rename lxml.etree.pyx and lxml.objectify.pyx to their correct module names and provide some legacy integration aid by keeping the original API header file names.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0118a547..942fcf2b 100644
--- a/setup.py
+++ b/setup.py
@@ -74,6 +74,8 @@ extra_options.update(setupinfo.extra_setup_args())
extra_options['package_data'] = {
'lxml': [
+ 'etree.h',
+ 'etree_api.h',
'lxml.etree.h',
'lxml.etree_api.h',
],