summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2019-11-25 10:53:51 +0100
committerStefan Behnel <stefan_ml@behnel.de>2019-11-25 10:53:51 +0100
commitda1395cb1226828cf0ea9b79c7c80e7d85eb8ffe (patch)
tree15cbb3a841d5a24b61fb2f2f792671cc212348f1 /setup.py
parent30c9da1522e18cc3f9dfeb1c8c2df82d5bef2732 (diff)
downloadpython-lxml-da1395cb1226828cf0ea9b79c7c80e7d85eb8ffe.tar.gz
Fix some links, formatting and supported Python versions.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py50
1 files changed, 26 insertions, 24 deletions
diff --git a/setup.py b/setup.py
index c433c41c..35e4d0cb 100644
--- a/setup.py
+++ b/setup.py
@@ -188,14 +188,16 @@ setup(
maintainer="lxml dev team",
maintainer_email="lxml-dev@lxml.de",
license="BSD",
- url="http://lxml.de/",
+ url="https://lxml.de/",
# Commented out because this causes distutils to emit warnings
# `Unknown distribution option: 'bugtrack_url'`
# which distract folks from real causes of problems when troubleshooting
# bugtrack_url="https://bugs.launchpad.net/lxml",
- description="Powerful and Pythonic XML processing library combining libxml2/libxslt with the ElementTree API.",
-
+ description=(
+ "Powerful and Pythonic XML processing library"
+ " combining libxml2/libxslt with the ElementTree API."
+ ),
long_description=((("""\
lxml is a Pythonic, mature binding for the libxml2 and libxslt libraries. It
provides safe and convenient access to these libraries using the ElementTree
@@ -205,7 +207,7 @@ It extends the ElementTree API significantly to offer support for XPath,
RelaxNG, XML Schema, XSLT, C14N and much more.
To contact the project, go to the `project home page
-<http://lxml.de/>`_ or see our bug tracker at
+<https://lxml.de/>`_ or see our bug tracker at
https://launchpad.net/lxml
In case you want to use the current in-development version of lxml,
@@ -217,27 +219,27 @@ install lxml from
https://github.com/lxml/lxml/tarball/master#egg=lxml-dev if you have
an appropriate version of Cython installed.
-""" + branch_link) % { "branch_version" : versioninfo.branch_version() }) +
+""" + branch_link) % {"branch_version": versioninfo.branch_version()}) +
versioninfo.changes()),
- classifiers = [
- versioninfo.dev_status(),
- 'Intended Audience :: Developers',
- 'Intended Audience :: Information Technology',
- 'License :: OSI Approved :: BSD License',
- 'Programming Language :: Cython',
- # NOTE: keep in sync with 'python_requires' list above.
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: C',
- 'Operating System :: OS Independent',
- 'Topic :: Text Processing :: Markup :: HTML',
- 'Topic :: Text Processing :: Markup :: XML',
- 'Topic :: Software Development :: Libraries :: Python Modules'
+ classifiers=[
+ versioninfo.dev_status(),
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'License :: OSI Approved :: BSD License',
+ 'Programming Language :: Cython',
+ # NOTE: keep in sync with 'python_requires' list above.
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: C',
+ 'Operating System :: OS Independent',
+ 'Topic :: Text Processing :: Markup :: HTML',
+ 'Topic :: Text Processing :: Markup :: XML',
+ 'Topic :: Software Development :: Libraries :: Python Modules'
],
**setup_extra_options()