summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCédric Krier <cedk@users.noreply.github.com>2019-08-02 15:28:33 +0200
committerStefan Behnel <stefan_ml@behnel.de>2019-08-02 15:28:33 +0200
commite65a38aca21d6d502df87fc59d1fbba5e0e4a855 (patch)
tree7b78d41c4190834d1e05f061eb6ea00fe6b850a4 /setup.py
parent548ce0777cd445c420f8be50e1f08c2257e5b386 (diff)
downloadpython-lxml-e65a38aca21d6d502df87fc59d1fbba5e0e4a855.tar.gz
Fill python_requires with proper metadata (GH-283)
* Fill python_requires with proper metadata * Remove Python 3.4 classifier
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d61a7714..8cd75588 100644
--- a/setup.py
+++ b/setup.py
@@ -56,6 +56,8 @@ if versioninfo.is_pre_release():
extra_options = {}
if 'setuptools' in sys.modules:
extra_options['zip_safe'] = False
+ extra_options['python_requires'] = (
+ '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, != 3.4.*')
try:
import pkg_resources
@@ -225,7 +227,6 @@ an appropriate version of Cython installed.
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',