summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Van Brunt <kmvanbrunt@gmail.com>2023-01-27 18:58:29 -0500
committerKevin Van Brunt <kmvanbrunt@gmail.com>2023-01-27 19:24:27 -0500
commitc6d1624f1a148a8e566ecfff4797caa39e14a140 (patch)
treeb6134ddf7a29e2f1afde8c7f60f0b2bc57bfa657
parent694718a970fb5af1fde5f2f60eb4bf1845c9b747 (diff)
downloadcmd2-git-c6d1624f1a148a8e566ecfff4797caa39e14a140.tar.gz
Removed Python 3.6 testing since the testing network no longer supports it on Ubuntu.
Added Python 3.11 testing support.
-rw-r--r--.github/workflows/ci.yml2
-rw-r--r--noxfile.py2
-rw-r--r--plugins/template/README.md5
-rw-r--r--plugins/template/build-pyenvs.sh2
-rw-r--r--plugins/template/noxfile.py2
-rw-r--r--plugins/template/setup.py1
6 files changed, 8 insertions, 6 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 92ac77dd..4f8bac8a 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -9,7 +9,7 @@ jobs:
strategy:
matrix:
os: [ubuntu-latest, macos-latest, windows-latest]
- python-version: ["3.6", "3.7", "3.8", "3.9", "3.10"]
+ python-version: ["3.7", "3.8", "3.9", "3.10", "3.11"]
fail-fast: false
runs-on: ${{ matrix.os }}
steps:
diff --git a/noxfile.py b/noxfile.py
index 427a7c3f..14b4d5a0 100644
--- a/noxfile.py
+++ b/noxfile.py
@@ -17,7 +17,7 @@ def docs(session):
)
-@nox.session(python=['3.6', '3.7', '3.8', '3.9', '3.10'])
+@nox.session(python=['3.7', '3.8', '3.9', '3.10', '3.11'])
@nox.parametrize('plugin', [None, 'ext_test', 'template', 'coverage'])
def tests(session, plugin):
if plugin is None:
diff --git a/plugins/template/README.md b/plugins/template/README.md
index 904b0541..509fa0c0 100644
--- a/plugins/template/README.md
+++ b/plugins/template/README.md
@@ -298,8 +298,9 @@ unit tests found in the `tests` directory.
### Use nox to run unit tests in multiple versions of python
-The included `noxfile.py` is setup to run the unit tests in python 3.6, 3.7, 3.8,
-and 3.9. You can run your unit tests in all of these versions of python by:
+The included `noxfile.py` is setup to run the unit tests in python 3.7, 3.8,
+3.9, 3.10, and 3.11 You can run your unit tests in all of these versions of
+python by:
```
$ nox
```
diff --git a/plugins/template/build-pyenvs.sh b/plugins/template/build-pyenvs.sh
index d64e11bd..f4084494 100644
--- a/plugins/template/build-pyenvs.sh
+++ b/plugins/template/build-pyenvs.sh
@@ -23,7 +23,7 @@
# virtualenvs will be added to '.python-version'. Feel free to modify
# this list, but note that this script intentionally won't install
# dev, rc, or beta python releases
-declare -a pythons=("3.7" "3.6" "3.8" "3.9")
+declare -a pythons=("3.7" "3.8" "3.9" "3.10" "3.11")
# function to find the latest patch of a minor version of python
function find_latest_version {
diff --git a/plugins/template/noxfile.py b/plugins/template/noxfile.py
index 75eab841..9872e193 100644
--- a/plugins/template/noxfile.py
+++ b/plugins/template/noxfile.py
@@ -1,7 +1,7 @@
import nox
-@nox.session(python=['3.6', '3.7', '3.8', '3.9'])
+@nox.session(python=['3.7', '3.8', '3.9', '3.10', '3.11'])
def tests(session):
session.install('invoke', './[test]')
session.run('invoke', 'pytest', '--junit', '--no-pty')
diff --git a/plugins/template/setup.py b/plugins/template/setup.py
index 18ab88cf..5fab9f06 100644
--- a/plugins/template/setup.py
+++ b/plugins/template/setup.py
@@ -39,6 +39,7 @@ setuptools.setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
],
# dependencies for development and testing
# $ pip install -e .[dev]