summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-01 19:01:05 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-01 19:01:05 +0200
commit431b5aa5140743a2dc59b01c74b82dc6c9866db9 (patch)
tree87e62fccd8fc57910113024bd323002cc05c5850 /setup.py
parent5cd91a31d26c359c6f9f31823db6e503974dc7f2 (diff)
downloadcmd2-git-431b5aa5140743a2dc59b01c74b82dc6c9866db9.tar.gz
Remove unnecessary runtime dependency on setuptools
The package does not seem to use setuptools or pkg_resources anywhere, and the dependency is probably leftover after migration to importlib.metadata.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4eb93cd2..123a045f 100755
--- a/setup.py
+++ b/setup.py
@@ -31,14 +31,13 @@ Programming Language :: Python :: Implementation :: CPython
Topic :: Software Development :: Libraries :: Python Modules
""".splitlines()))) # noqa: E128
-SETUP_REQUIRES = ['setuptools_scm >= 3.0']
+SETUP_REQUIRES = ['setuptools >= 34.4', 'setuptools_scm >= 3.0']
INSTALL_REQUIRES = [
'attrs >= 16.3.0',
'colorama >= 0.3.7',
'importlib_metadata>=1.6.0;python_version<"3.8"',
'pyperclip >= 1.6',
- 'setuptools >= 34.4',
'wcwidth >= 0.1.7',
]