summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKevin Van Brunt <kmvanbrunt@gmail.com>2019-02-23 14:30:18 -0500
committerKevin Van Brunt <kmvanbrunt@gmail.com>2019-02-23 14:30:18 -0500
commit559983db44bb6e294d668eb8b7341ae5c5d5c18c (patch)
tree9466bc0dad0e4d83a03e6c8b342964f5f00aaff5 /setup.py
parent05c4bb0d3cd3b1424741b1cc963241d610dc1a3e (diff)
downloadcmd2-git-559983db44bb6e294d668eb8b7341ae5c5d5c18c.tar.gz
Remove test dependency on argcomplete
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index f62bb39d..fa56b08d 100755
--- a/setup.py
+++ b/setup.py
@@ -75,8 +75,7 @@ EXTRAS_REQUIRE = {
# Python 3.4 and earlier require contextlib2 for temporarily redirecting stderr and stdout
":python_version<'3.5'": ['contextlib2', 'typing'],
# Extra dependencies for running unit tests
- 'test': ["argcomplete ; sys_platform!='win32'", # include argcomplete tests where available
- "gnureadline; sys_platform=='darwin'", # include gnureadline on macOS to ensure it is available in tox env
+ 'test': ["gnureadline; sys_platform=='darwin'", # include gnureadline on macOS to ensure it is available in tox env
"mock ; python_version<'3.6'", # for python 3.5 and earlier we need the third party mock module
'codecov', 'pytest', 'pytest-cov', 'pytest-mock'],
# development only dependencies: install with 'pip install -e .[dev]'