summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTodd Leonhardt <todd.leonhardt@gmail.com>2018-10-24 10:13:59 -0400
committerTodd Leonhardt <todd.leonhardt@gmail.com>2018-10-24 10:13:59 -0400
commit88a50d443626c8a1d0708c5f28d3ae5ecb21eb1b (patch)
treee6fdf5540eb5b1305ca84e32e9c52d3efd58daca /setup.py
parent058cb0ab85415d8d76838c80f619950ba6be0480 (diff)
downloadcmd2-git-88a50d443626c8a1d0708c5f28d3ae5ecb21eb1b.tar.gz
Attempt 3 at getting VSTS tox build working
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 607bc346..41af5316 100755
--- a/setup.py
+++ b/setup.py
@@ -75,6 +75,7 @@ EXTRAS_REQUIRE = {
":python_version<'3.5'": ['contextlib2', 'typing'],
# Extra dependencies for running unit tests
'test': ["argcomplete ; sys_platform!='win32'", # include argcomplete tests where available
+ "gnureadline; sys_platform=='darwin'", # include gnureadline on macOS to ensure it is available in tox env
"mock ; python_version<'3.6'", # for python 3.5 and earlier we need the third party mock module
'codecov', 'pytest', 'pytest-cov', 'pytest-mock'],
# development only dependencies: install with 'pip install -e .[dev]'