summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEric Lin <anselor@gmail.com>2021-06-10 11:38:43 -0400
committerKevin Van Brunt <kmvanbrunt@gmail.com>2021-06-14 11:28:25 -0400
commitbf1f8ebf09a14b039c7d8b5a5fd790daedcce2a4 (patch)
tree1f15edc8818647def4c6f1b37ffbae866b5df865 /setup.py
parentb94d04a9d82258c4b25584de97c707c0e3804f5b (diff)
downloadcmd2-git-bf1f8ebf09a14b039c7d8b5a5fd790daedcce2a4.tar.gz
Change mypy and lint github steps to use nox/invoke to make CI validation configuration/commands match developer local commands.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 10 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 3289dbd1..d2d2e955 100755
--- a/setup.py
+++ b/setup.py
@@ -66,19 +66,24 @@ EXTRAS_REQUIRE = {
],
# development only dependencies: install with 'pip install -e .[dev]'
'dev': [
- "pytest>=4.6",
'codecov',
+ 'doc8',
+ 'flake8',
+ 'invoke',
+ 'mypy==0.902',
+ 'nox',
+ "pytest>=4.6",
'pytest-cov',
'pytest-mock',
- 'nox',
- 'flake8',
'sphinx',
'sphinx-rtd-theme',
'sphinx-autobuild',
- 'doc8',
- 'invoke',
'twine>=1.11',
],
+ 'validate': [
+ 'flake8',
+ 'mypy==0.902',
+ ],
}
PACKAGE_DATA = {