summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorkotfu <kotfu@kotfu.net>2018-07-30 20:43:55 -0600
committerkotfu <kotfu@kotfu.net>2018-07-30 20:43:55 -0600
commitc184dc66e0d041fc37f730077aade63105a59889 (patch)
tree93ca02ac5805dc1d81b87df1d673fc1da2426f46 /setup.py
parent82e06328c083269ed3405690b1b6b26dcda280a0 (diff)
downloadcmd2-git-c184dc66e0d041fc37f730077aade63105a59889.tar.gz
Add all dev dependencies (even from tox.ini)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e67e14b6..0425cf7e 100755
--- a/setup.py
+++ b/setup.py
@@ -73,8 +73,10 @@ EXTRAS_REQUIRE = {
# development only dependencies
# install with 'pip install -e .[dev]'
'dev': [
- 'pytest', 'pytest-cov', 'tox', 'pylint', 'sphinx', 'sphinx-rtd-theme',
- 'sphinx-autobuild', 'invoke', 'twine>=1.11',
+ # for python 3.5 and earlier we need the third party mock module
+ "mock ; python_version<'3.6'",
+ 'pytest', 'codecov', 'pytest-cov', 'pytest-mock', 'tox', 'pylint',
+ 'sphinx', 'sphinx-rtd-theme', 'sphinx-autobuild', 'invoke', 'twine>=1.11',
]
}