diff options
author | Todd Leonhardt <todd.leonhardt@gmail.com> | 2018-12-06 01:24:19 -0500 |
---|---|---|
committer | Todd Leonhardt <todd.leonhardt@gmail.com> | 2018-12-06 01:24:19 -0500 |
commit | c689e74fed45bf1a7b2908defc343d35f31dff71 (patch) | |
tree | 3c1904debb429274d2fac316300a8b75b200a66c /setup.py | |
parent | 709af49a7f161c98260cc5ddda736987fb0f1f23 (diff) | |
download | cmd2-git-c689e74fed45bf1a7b2908defc343d35f31dff71.tar.gz |
Fix flake8 issues
This commit contains a very large number of trivial changes in order to fix flake8 errors and warnings. Predominantly these are whitespace changes.
Additionally, the build for Python 3.7 on TravisCI has been tweaked to fail if there are any flake8 errors using the following commandline:
* flake8 . --count --ignore=E252 --max-complexity=31 --max-line-length=127 --show-source --statistics
NOTE: In the future the max cyclomatic complexity should be lowered, but some improvements need to be made first.
One flake8 error is being ignored entirely:
* E252 missing whitespace around parameter equals
* ignored because it doesn't correctly deal with default argument values after a type hint
A few flake8 errors are being selectively ignored in certain files:
* C901 fuction is too complex
* ignored in argparse_completer.py because the complex code is an override of argparse complexity
* E302 expected 2 blank lines after ...
* ignored in all unit test files for convenience
* F401 module imported but unused
* ignored in cmd2/__init__.py because imports are for convenience of cmd2 developers and backwards compatibility
* F821 undefined name
* ignored in cmd2 script files which are intended to run only within cmd2 applications via pyscript where "app" and "cmd" are defined
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -63,7 +63,7 @@ Programming Language :: Python :: 3.6 Programming Language :: Python :: 3.7 Programming Language :: Python :: Implementation :: CPython Topic :: Software Development :: Libraries :: Python Modules -""".splitlines()))) +""".splitlines()))) # noqa: E128 SETUP_REQUIRES = ['setuptools_scm'] @@ -83,7 +83,7 @@ EXTRAS_REQUIRE = { 'dev': ["mock ; python_version<'3.6'", # for python 3.5 and earlier we need the third party mock module 'pytest', 'codecov', 'pytest-cov', 'pytest-mock', 'tox', 'pylint', 'sphinx', 'sphinx-rtd-theme', 'sphinx-autobuild', 'invoke', 'twine>=1.11', - ] + ] } setup( |