summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTodd Leonhardt <todd.leonhardt@gmail.com>2018-09-20 21:35:34 -0400
committerTodd Leonhardt <todd.leonhardt@gmail.com>2018-09-20 21:35:34 -0400
commitd750f9f8a593cdf9929e03d8da1d35e680513526 (patch)
tree79553317a073563930c06cda15e9fe6faf53b0b8 /setup.py
parente74976ea38f7e7c625071038c5b3c022942643f3 (diff)
downloadcmd2-git-d750f9f8a593cdf9929e03d8da1d35e680513526.tar.gz
Removed use of type argument in attr.ib() since that wasn't added until version 17.3.0.
Also: - In setup.py require version of attrs to be >= 16.3.0 - I think this is right, if there are any issues we can bump this to version 17.1.0
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 53645eff..2947c2ea 100755
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,7 @@ Topic :: Software Development :: Libraries :: Python Modules
SETUP_REQUIRES = ['setuptools_scm']
-INSTALL_REQUIRES = ['pyperclip >= 1.5.27', 'colorama', 'attrs']
+INSTALL_REQUIRES = ['pyperclip >= 1.5.27', 'colorama', 'attrs >= 16.3.0']
EXTRAS_REQUIRE = {
# Windows also requires pyreadline to ensure tab completion works