summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKevin Van Brunt <kmvanbrunt@gmail.com>2018-10-11 22:12:32 -0400
committerKevin Van Brunt <kmvanbrunt@gmail.com>2018-10-11 22:12:32 -0400
commitd80aeb36f92f55ef0857be78b804ff5bf7d75fb9 (patch)
treeb9c7b6f59360ee1fb361cfa76f2acff3c07dec00 /setup.py
parent7ef96d39fa971d8624fe46b9508067f0f1a78950 (diff)
downloadcmd2-git-d80aeb36f92f55ef0857be78b804ff5bf7d75fb9.tar.gz
Using wcwidth to calculate display width of prompt
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 861813c7..764ac8d3 100755
--- a/setup.py
+++ b/setup.py
@@ -66,13 +66,11 @@ Topic :: Software Development :: Libraries :: Python Modules
SETUP_REQUIRES = ['setuptools_scm']
-INSTALL_REQUIRES = ['pyperclip >= 1.5.27', 'colorama', 'attrs >= 16.3.0']
+INSTALL_REQUIRES = ['pyperclip >= 1.5.27', 'colorama', 'attrs >= 16.3.0', 'wcwidth']
EXTRAS_REQUIRE = {
# Windows also requires pyreadline to ensure tab completion works
":sys_platform=='win32'": ['pyreadline'],
- # POSIX OSes also require wcwidth for correctly estimating the displayed width of unicode chars
- ":sys_platform!='win32'": ['wcwidth'],
# Python 3.4 and earlier require contextlib2 for temporarily redirecting stderr and stdout
":python_version<'3.5'": ['contextlib2', 'typing'],
# Extra dependencies for running unit tests