diff options
author | Todd Leonhardt <todd.leonhardt@gmail.com> | 2022-07-14 12:59:16 -0400 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-07-14 12:59:16 -0400 |
commit | e95af81acb9c6829c969f76e40658356a4808edb (patch) | |
tree | b728a33789c33cae913abb16b8d40ee2dd6ff7cf /setup.py | |
parent | f38194860572c32c4c1f475b16a901eb832d34e6 (diff) | |
download | cmd2-git-e95af81acb9c6829c969f76e40658356a4808edb.tar.gz |
Use latest version of mypy and fix type hinting accordingly (#1239)
* Use latest version of mypy and fix type hinting accordingly
Also:
- Update Pipfile to never require mock since we only support Python 3.6+
- Remove Azure Pipelines badge from Readme and fix section links there
- Added an "inv format" task to run black and isort to auto-format all code before a commit
* Try to fix type errors on versions prior to 3.8
* Restored correct types in argparse_custom.py
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -68,7 +68,7 @@ EXTRAS_REQUIRE = { 'doc8', 'flake8', 'invoke', - 'mypy==0.902', + 'mypy', 'nox', "pytest>=4.6", 'pytest-cov', @@ -80,7 +80,7 @@ EXTRAS_REQUIRE = { ], 'validate': [ 'flake8', - 'mypy==0.902', + 'mypy', 'types-pkg-resources', ], } |