summaryrefslogtreecommitdiff
path: root/tasks.py
diff options
context:
space:
mode:
authorTodd Leonhardt <todd.leonhardt@gmail.com>2019-07-06 16:21:17 -0400
committerTodd Leonhardt <todd.leonhardt@gmail.com>2019-07-06 16:21:17 -0400
commitbbae658da66438340bd6b8b7aa15998561c1a853 (patch)
treeb07056076c603edebd701df8e50f7a879eff519a /tasks.py
parent5dea50a8a376532da05a25eb0f9721f18490e346 (diff)
parente18013e7f6be6721531cde163ec4697eac247270 (diff)
downloadcmd2-git-bbae658da66438340bd6b8b7aa15998561c1a853.tar.gz
Merge branch 'master' into docstructure
# Conflicts: # setup.py
Diffstat (limited to 'tasks.py')
-rw-r--r--tasks.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/tasks.py b/tasks.py
index c2ae9b17..b679e594 100644
--- a/tasks.py
+++ b/tasks.py
@@ -239,5 +239,5 @@ namespace.add_task(pypi_test)
@invoke.task
def flake8(context):
"Run flake8 linter and tool for style guide enforcement"
- context.run("flake8 --ignore=E252,W503 --max-complexity=31 --max-line-length=127 --show-source --statistics")
+ context.run("flake8 --ignore=E252,W503 --max-complexity=31 --max-line-length=127 --show-source --statistics --exclude=.git,__pycache__,.tox,.eggs,*.egg,.venv,.idea,.pytest_cache,.vscode,build,dist,htmlcov")
namespace.add_task(flake8)