summaryrefslogtreecommitdiff
path: root/plugins/ext_test/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ext_test/setup.py')
-rw-r--r--plugins/ext_test/setup.py16
1 files changed, 2 insertions, 14 deletions
diff --git a/plugins/ext_test/setup.py b/plugins/ext_test/setup.py
index 3384527c..4bfe1b79 100644
--- a/plugins/ext_test/setup.py
+++ b/plugins/ext_test/setup.py
@@ -20,23 +20,18 @@ setuptools.setup(
# 'relative_to': __file__,
# 'git_describe_command': 'git describe --dirty --tags --long --match plugin-ext-test*'
# },
-
description='External test plugin for cmd2. Allows for external invocation of commands as if from a cmd2 pyscript',
long_description=long_description,
long_description_content_type='text/markdown',
keywords='cmd2 test plugin',
-
author='Eric Lin',
author_email='anselor@gmail.com',
url='https://github.com/python-cmd2/cmd2/tree/master/plugins/ext_test',
license='MIT',
-
packages=['cmd2_ext_test'],
-
python_requires='>=3.5',
install_requires=['cmd2 >= 0.9.4, <=2'],
setup_requires=['setuptools_scm >= 3.0'],
-
classifiers=[
'Development Status :: 5 - Production/Stable',
'Environment :: Console',
@@ -51,17 +46,10 @@ setuptools.setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
],
-
# dependencies for development and testing
# $ pip install -e .[dev]
extras_require={
- 'test': [
- 'codecov',
- 'coverage',
- 'pytest',
- 'pytest-cov',
- ],
- 'dev': ['setuptools_scm', 'pytest', 'codecov', 'pytest-cov',
- 'pylint', 'invoke', 'wheel', 'twine']
+ 'test': ['codecov', 'coverage', 'pytest', 'pytest-cov',],
+ 'dev': ['setuptools_scm', 'pytest', 'codecov', 'pytest-cov', 'pylint', 'invoke', 'wheel', 'twine'],
},
)