summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py44
1 files changed, 27 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 123a045f..324ebd28 100755
--- a/setup.py
+++ b/setup.py
@@ -12,8 +12,12 @@ DESCRIPTION = "cmd2 - quickly build feature-rich and user-friendly interactive c
with codecs.open('README.md', encoding='utf8') as f:
LONG_DESCRIPTION = f.read()
-CLASSIFIERS = list(filter(None, map(str.strip,
-"""
+CLASSIFIERS = list(
+ filter(
+ None,
+ map(
+ str.strip,
+ """
Development Status :: 5 - Production/Stable
Environment :: Console
Operating System :: OS Independent
@@ -29,7 +33,10 @@ Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
Programming Language :: Python :: Implementation :: CPython
Topic :: Software Development :: Libraries :: Python Modules
-""".splitlines()))) # noqa: E128
+""".splitlines(),
+ ),
+ )
+) # noqa: E128
SETUP_REQUIRES = ['setuptools >= 34.4', 'setuptools_scm >= 3.0']
@@ -55,24 +62,27 @@ EXTRAS_REQUIRE = {
'pytest-mock',
],
# development only dependencies: install with 'pip install -e .[dev]'
- 'dev': ["mock ; python_version<'3.6'", # for python 3.5 we need the third party mock module
- "pytest>=4.6",
- 'codecov',
- 'pytest-cov',
- 'pytest-mock',
- "nox==2019.11.9 ; python_version=='3.5.2'",
- "nox ; python_version>'3.5.2'",
- 'flake8',
- 'sphinx', 'sphinx-rtd-theme', 'sphinx-autobuild', 'doc8',
- 'invoke', 'twine>=1.11',
- ]
+ 'dev': [
+ "mock ; python_version<'3.6'", # for python 3.5 we need the third party mock module
+ "pytest>=4.6",
+ 'codecov',
+ 'pytest-cov',
+ 'pytest-mock',
+ "nox==2019.11.9 ; python_version=='3.5.2'",
+ "nox ; python_version>'3.5.2'",
+ 'flake8',
+ 'sphinx',
+ 'sphinx-rtd-theme',
+ 'sphinx-autobuild',
+ 'doc8',
+ 'invoke',
+ 'twine>=1.11',
+ ],
}
setup(
name="cmd2",
- use_scm_version={
- 'git_describe_command': 'git describe --dirty --tags --long --exclude plugin-*'
- },
+ use_scm_version={'git_describe_command': 'git describe --dirty --tags --long --exclude plugin-*'},
description=DESCRIPTION,
long_description=LONG_DESCRIPTION,
long_description_content_type='text/markdown',