summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlex Gaynor <alex.gaynor@gmail.com>2021-02-07 16:06:02 -0500
committerGitHub <noreply@github.com>2021-02-07 15:06:02 -0600
commitab537a610dbde082ab2910b2dbaa648aa03640d0 (patch)
tree138eb8a3d4799bb3258ed87be1ef0c75e1015299 /setup.py
parentcac6703ccafafa4f879bad1d69ae926fb4e426ca (diff)
downloadcryptography-ab537a610dbde082ab2910b2dbaa648aa03640d0.tar.gz
Try to assist folks having issues with older pips (#5757)
* Try to assist folks having issues with older pips * Update setup.py * Update setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 15 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 58de2f4a8..9fb3e3200 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,21 @@ import sys
from setuptools import find_packages, setup
-from setuptools_rust import RustExtension
+try:
+ from setuptools_rust import RustExtension
+except ImportError:
+ print(
+ """
+ =============================DEBUG ASSISTANCE==========================
+ If you are seeing an error here please try the following to
+ successfully install cryptography:
+
+ Upgrade to the latest pip and try again. This will fix errors for most
+ users. See: https://pip.pypa.io/en/stable/installing/#upgrading-pip
+ =============================DEBUG ASSISTANCE==========================
+ """
+ )
+ raise
base_dir = os.path.dirname(__file__)