summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMatthew Ryan <54719826+akamaryan@users.noreply.github.com>2023-03-15 03:47:58 -0700
committerGitHub <noreply@github.com>2023-03-15 06:47:58 -0400
commitc5eb29860e63e5099d0802fc44ea756260e6775e (patch)
tree029174b997b883d40175d65fa96cc7da1951c116 /setup.py
parent6c39999b40d8794945a8cd47106725334d6d3ae3 (diff)
downloadcryptography-c5eb29860e63e5099d0802fc44ea756260e6775e.tar.gz
Python 3.6 compatibility fix. (#8516)
* Python 3.6 compatibility fix. The capture_output argument to subprocess.run() was not introduced until Python 3.7. Use stdout=subprocess.PIPE and stderr=subprocess.PIPE instead, which is equivalent. * Update pyproject.toml * Black --------- Co-authored-by: Matthew Ryan <matt.ryan@nominum.com> Co-authored-by: Paul Kehrer <paul.l.kehrer@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 2d084d1ef..e1adff269 100644
--- a/setup.py
+++ b/setup.py
@@ -101,7 +101,8 @@ except: # noqa: E722
# If for any reason `rustc --version` fails, silently ignore it
rustc_output = subprocess.run(
["rustc", "--version"],
- capture_output=True,
+ stdout=subprocess.PIPE,
+ stderr=subprocess.PIPE,
timeout=0.5,
encoding="utf8",
check=True,