diff options
author | Alex Gaynor <alex.gaynor@gmail.com> | 2020-12-09 00:10:10 -0500 |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-12-08 23:10:10 -0600 |
commit | ff12a375521e5b702d9d58c8a04604c65496eb54 (patch) | |
tree | 39b230f00354c2b8fbd3eee9c5c343eda6ea41d1 /setup.py | |
parent | d63473112119993bc5d556e0c37b03d5e5b560f0 (diff) | |
download | cryptography-ff12a375521e5b702d9d58c8a04604c65496eb54.tar.gz |
Remove Python2 from CI and code that branched on it (#5607)
* Remove Python2 from CI and code that branched on it
* Update setup.py
Co-authored-by: Hugo van Kemenade <hugovk@users.noreply.github.com>
* remove
* review feedback
Co-authored-by: Hugo van Kemenade <hugovk@users.noreply.github.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 2 insertions, 6 deletions
@@ -63,9 +63,8 @@ try: "Operating System :: POSIX :: Linux", "Operating System :: Microsoft :: Windows", "Programming Language :: Python", - "Programming Language :: Python :: 2", - "Programming Language :: Python :: 2.7", "Programming Language :: Python :: 3", + "Programming Language :: Python :: 3 :: Only", "Programming Language :: Python :: 3.6", "Programming Language :: Python :: 3.7", "Programming Language :: Python :: 3.8", @@ -79,13 +78,10 @@ try: where="src", exclude=["_cffi_src", "_cffi_src.*"] ), include_package_data=True, - python_requires=( - ">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,!=3.5.*" - ), + python_requires=">=3.6", install_requires=["six >= 1.4.1"] + setup_requirements, setup_requires=setup_requirements, extras_require={ - ":python_version < '3'": ["enum34", "ipaddress"], "test": [ "pytest>=3.6.0,!=3.9.0,!=3.9.1,!=3.9.2", "pretend", |