diff options
author | Pierre Gergondet <pierre.gergondet@gmail.com> | 2018-03-26 12:47:58 +0900 |
---|---|---|
committer | Paul Ganssle <paul@ganssle.io> | 2018-03-26 09:16:58 -0400 |
commit | f39c1ae6fb6082464077d681fdc80a4ab3679466 (patch) | |
tree | 9ebebb2540924a1d7c718b8078d571e4b55332eb /setup.py | |
parent | 5be0893d1253539b2634a5313e8ddf378b7969de (diff) | |
download | dateutil-git-f39c1ae6fb6082464077d681fdc80a4ab3679466.tar.gz |
Open README.rst with utf-8 encoding
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -9,6 +9,8 @@ from setuptools.command.test import test as TestCommand from distutils.version import LooseVersion import warnings +import io + if isfile("MANIFEST"): os.unlink("MANIFEST") @@ -27,7 +29,7 @@ class Unsupported(TestCommand): PACKAGES = find_packages(where='.', exclude=['dateutil.test']) def README(): - with open('README.rst') as f: + with io.open('README.rst', encoding='utf-8') as f: readme_lines = f.readlines() # The .. doctest directive is not supported by PyPA |