diff options
author | Christian Heimes <christian@python.org> | 2017-01-28 11:19:27 +0100 |
---|---|---|
committer | Christian Heimes <christian@python.org> | 2017-01-28 14:51:01 +0100 |
commit | dc1b609809a5919de0075dc64f36eb043073c59a (patch) | |
tree | 2a3dfa404fef7973fa5b53441672decb62383611 | |
parent | ef6c918260b4bd3b58ac2000a1222b34b96f222d (diff) | |
download | defusedxml-git-dc1b609809a5919de0075dc64f36eb043073c59a.tar.gz |
check flake8 and docs
-rw-r--r-- | tox.ini | 33 |
1 files changed, 32 insertions, 1 deletions
@@ -1,5 +1,5 @@ [tox] -envlist = py27,py34,py35,py36 +envlist = py27,py34,py35,py36,pep8py2,pep8py3,doc skip_missing_interpreters = true [testenv] @@ -7,3 +7,34 @@ commands = {envpython} setup.py test deps = lxml + +[testenv:pep8py2] +basepython = python2.7 +deps = + flake8 +commands = + {envpython} -m flake8 + +[testenv:pep8py3] +basepython = python3 +deps = + flake8 +commands = + {envpython} -m flake8 + +[testenv:doc] +basepython = python3 +deps = + docutils +commands = + python setup.py check --restructuredtext --metadata --strict + +[pytest] +norecursedirs = build .tox +python_files = tests.py + +[flake8] +exclude = .tox,*.egg,dist,build,other +show-source = true +ignore = E402, F811 +max-line-length = 98 |