summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@python.org>2013-02-20 13:11:03 +0100
committerChristian Heimes <christian@python.org>2013-02-20 13:11:03 +0100
commit97decea4eb174a9313f30c629a1afb42646d144b (patch)
tree87d5ecba50785d24bb6f6c08cfb91caacf0ab126 /setup.py
downloaddefusedxml-git-97decea4eb174a9313f30c629a1afb42646d144b.tar.gz
Add missing parser_list argument to sax.make_parser()
The argument is ignored, though. (thanks to Florian Apolloner)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py58
1 files changed, 58 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..82413e4
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,58 @@
+#!/usr/bin/env python
+from __future__ import absolute_import
+import sys
+from distutils.core import setup, Command
+import subprocess
+
+import defusedxml
+
+class PyTest(Command):
+ user_options = []
+ def initialize_options(self):
+ pass
+ def finalize_options(self):
+ pass
+ def run(self):
+ errno = subprocess.call([sys.executable, "tests.py"])
+ raise SystemExit(errno)
+
+
+long_description = []
+with open("README.txt") as f:
+ long_description.append(f.read())
+with open("CHANGES.txt") as f:
+ long_description.append(f.read())
+
+setup(
+ name="defusedxml",
+ version=defusedxml.__version__,
+ cmdclass={"test": PyTest},
+ packages=["defusedxml"],
+ author="Christian Heimes",
+ author_email="christian@python.org",
+ maintainer="Christian Heimes",
+ maintainer_email="christian@python.org",
+ url="https://bitbucket.org/tiran/defusedxml",
+ download_url="http://pypi.python.org/pypi/defusedxml",
+ keywords="xml bomb DoS",
+ platforms="all",
+ license="PSFL",
+ description="XML bomb protection for Python stdlib modules",
+ long_description="\n".join(long_description),
+ classifiers=[
+ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: Python Software Foundation License",
+ "Natural Language :: English",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.6",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.1",
+ "Programming Language :: Python :: 3.2",
+ "Programming Language :: Python :: 3.3",
+ "Topic :: Text Processing :: Markup :: XML",
+ ],
+)
+