summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Halley <halley@dnspython.org>2023-05-06 07:16:32 -0700
committerBob Halley <halley@dnspython.org>2023-05-06 07:16:32 -0700
commita2d06fe48fecad0a6b519dd45c10b364500cd83d (patch)
tree9d821a065fb668c989d9c55619c70ee1d0a797ef
parentbf8deda6da437ec5fdaaf5261b8674deb8e6d31c (diff)
downloaddnspython-a2d06fe48fecad0a6b519dd45c10b364500cd83d.tar.gz
Add support for ruff linter.
-rw-r--r--Makefile3
-rw-r--r--pyproject.toml3
2 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e0f7ccd..94cd586 100644
--- a/Makefile
+++ b/Makefile
@@ -67,6 +67,9 @@ polint:
poflake:
poetry run flake8 dns
+poruff:
+ poetry run ruff dns
+
pocov:
poetry run coverage run --branch -m pytest
poetry run coverage html --include 'dns/*'
diff --git a/pyproject.toml b/pyproject.toml
index 30cf10f..d39a599 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -73,3 +73,6 @@ requires = ["poetry-core"]
build-backend = "poetry.core.masonry.api"
[tool.setuptools_scm]
+
+[tool.ruff]
+ignore = ['E741', 'F401']