diff options
author | Bob Halley <halley@dnspython.org> | 2023-05-06 07:16:32 -0700 |
---|---|---|
committer | Bob Halley <halley@dnspython.org> | 2023-05-06 07:16:32 -0700 |
commit | a2d06fe48fecad0a6b519dd45c10b364500cd83d (patch) | |
tree | 9d821a065fb668c989d9c55619c70ee1d0a797ef | |
parent | bf8deda6da437ec5fdaaf5261b8674deb8e6d31c (diff) | |
download | dnspython-a2d06fe48fecad0a6b519dd45c10b364500cd83d.tar.gz |
Add support for ruff linter.
-rw-r--r-- | Makefile | 3 | ||||
-rw-r--r-- | pyproject.toml | 3 |
2 files changed, 6 insertions, 0 deletions
@@ -67,6 +67,9 @@ polint: poflake: poetry run flake8 dns +poruff: + poetry run ruff dns + pocov: poetry run coverage run --branch -m pytest poetry run coverage html --include 'dns/*' diff --git a/pyproject.toml b/pyproject.toml index 30cf10f..d39a599 100644 --- a/pyproject.toml +++ b/pyproject.toml @@ -73,3 +73,6 @@ requires = ["poetry-core"] build-backend = "poetry.core.masonry.api" [tool.setuptools_scm] + +[tool.ruff] +ignore = ['E741', 'F401'] |