summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTerence Honles <terence@honles.com>2016-03-14 15:58:33 -0700
committerTerence Honles <terence@honles.com>2016-03-14 15:58:33 -0700
commit82b2686055d28a3d8cffbbf0a8964423f5fe21c6 (patch)
tree7705d834392df51cde87e15586f334aea7394647
parentd9c307f1cadeeafff69408d25d0aed48d2181d79 (diff)
downloadfusepy-82b2686055d28a3d8cffbbf0a8964423f5fe21c6.tar.gz
updating minimum version to Python 2.6
-rw-r--r--README.rst7
-rw-r--r--fuse.py6
-rw-r--r--fusell.py4
-rwxr-xr-xsetup.py18
4 files changed, 8 insertions, 27 deletions
diff --git a/README.rst b/README.rst
index 7a12f97..828da7e 100644
--- a/README.rst
+++ b/README.rst
@@ -8,12 +8,7 @@ The original version of ``fusepy`` was hosted on `Google Code`_, but is now
`officially hosted on GitHub`_.
``fusepy`` is written in 2x syntax, but trying to pay attention to bytes and
-other changes 3x would care about. The only incompatible changes between 2x and
-3x are the change in syntax for number literals and exceptions. These issues
-are fixed using the 2to3 tool when installing the package, or runnning::
-
- 2to3 -f numliterals -f except -w fuse.py
-
+other changes 3x would care about.
examples
--------
diff --git a/fuse.py b/fuse.py
index 7564c7d..6ff7de2 100644
--- a/fuse.py
+++ b/fuse.py
@@ -477,7 +477,7 @@ class FUSE(object):
try:
return func(*args, **kwargs) or 0
- except OSError, e:
+ except OSError as e:
return -(e.errno or EFAULT)
except:
print_exc()
@@ -825,7 +825,7 @@ class Operations(object):
if path != '/':
raise FuseOSError(ENOENT)
- return dict(st_mode=(S_IFDIR | 0755), st_nlink=2)
+ return dict(st_mode=(S_IFDIR | 0o755), st_nlink=2)
def getxattr(self, path, name, position=0):
raise FuseOSError(ENOTSUP)
@@ -947,7 +947,7 @@ class LoggingMixIn:
try:
ret = getattr(self, op)(path, *args)
return ret
- except OSError, e:
+ except OSError as e:
ret = str(e)
raise
finally:
diff --git a/fusell.py b/fusell.py
index 5c39ec7..ff5600a 100644
--- a/fusell.py
+++ b/fusell.py
@@ -483,7 +483,7 @@ class FUSELL(object):
reply_err
"""
if ino == 1:
- attr = {'st_ino': 1, 'st_mode': S_IFDIR | 0755, 'st_nlink': 2}
+ attr = {'st_ino': 1, 'st_mode': S_IFDIR | 0o755, 'st_nlink': 2}
self.reply_attr(req, attr, 1.0)
else:
self.reply_err(req, ENOENT)
@@ -654,4 +654,4 @@ class FUSELL(object):
Valid replies:
reply_err
"""
- self.reply_err(req, 0) \ No newline at end of file
+ self.reply_err(req, 0)
diff --git a/setup.py b/setup.py
index 8a3efc4..f8a1667 100755
--- a/setup.py
+++ b/setup.py
@@ -4,18 +4,12 @@ from __future__ import with_statement
from setuptools import setup
-try:
- from lib2to3 import refactor
- fixers = set(refactor.get_fixers_from_package('lib2to3.fixes'))
-except ImportError:
- fixers = set()
-
with open('README') as readme:
documentation = readme.read()
setup(
name = 'fusepy',
- version = '2.0.2',
+ version = '2.0.3',
description = 'Simple ctypes bindings for FUSE',
long_description = documentation,
@@ -27,21 +21,13 @@ setup(
py_modules=['fuse'],
url = 'http://github.com/terencehonles/fusepy',
- use_2to3 = True,
- # only use the following fixers (everything else is already compatible)
- use_2to3_exclude_fixers = fixers - set([
- 'lib2to3.fixes.fix_except',
- 'lib2to3.fixes.fix_future',
- 'lib2to3.fixes.fix_numliterals',
- ]),
-
classifiers = [
'Intended Audience :: Developers',
'License :: OSI Approved :: ISC License (ISCL)',
'Operating System :: MacOS',
'Operating System :: POSIX',
'Operating System :: Unix',
- 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 3',
'Topic :: System :: Filesystems',
]