summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTerence Honles <terence@honles.com>2012-04-23 19:28:44 -0700
committerTerence Honles <terence@honles.com>2012-04-23 19:28:44 -0700
commitfb8a3b11b7269d3f6d5c9e57d6784c503b0ce649 (patch)
tree1f8048cec87b14651aa43e5875091296084c30e0
parent7457fb93236222c7786e5fb468a3ff1732abbaa9 (diff)
downloadfusepy-fb8a3b11b7269d3f6d5c9e57d6784c503b0ce649.tar.gz
organizing examples and package files
-rw-r--r--.gitignore11
-rwxr-xr-xexamples/context.py (renamed from context.py)0
-rwxr-xr-xexamples/loopback.py (renamed from loopback.py)0
-rwxr-xr-xexamples/memory.py (renamed from memory.py)0
-rwxr-xr-xexamples/memory3.py (renamed from memory3.py)0
-rwxr-xr-xexamples/memoryll.py (renamed from memoryll.py)0
-rwxr-xr-xexamples/sftp.py (renamed from sftp.py)0
-rw-r--r--fuse/__init__.py (renamed from __init__.py)2
-rw-r--r--fuse/fuse.py (renamed from fuse.py)2
-rw-r--r--fuse/fuse24.py (renamed from fuse24.py)0
-rw-r--r--fuse/fuse3.py (renamed from fuse3.py)0
-rwxr-xr-xsetup.py22
12 files changed, 24 insertions, 13 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..c7940cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.py[oc]
+*~
+*.swp
+/bin
+/include
+/lib
+/lib64
+/system
+/build
+/dist
+/fusepy.egg-info
diff --git a/context.py b/examples/context.py
index 2609aa0..2609aa0 100755
--- a/context.py
+++ b/examples/context.py
diff --git a/loopback.py b/examples/loopback.py
index 5ce16ed..5ce16ed 100755
--- a/loopback.py
+++ b/examples/loopback.py
diff --git a/memory.py b/examples/memory.py
index 246b305..246b305 100755
--- a/memory.py
+++ b/examples/memory.py
diff --git a/memory3.py b/examples/memory3.py
index e5cbad7..e5cbad7 100755
--- a/memory3.py
+++ b/examples/memory3.py
diff --git a/memoryll.py b/examples/memoryll.py
index 307a1af..307a1af 100755
--- a/memoryll.py
+++ b/examples/memoryll.py
diff --git a/sftp.py b/examples/sftp.py
index 019fb29..019fb29 100755
--- a/sftp.py
+++ b/examples/sftp.py
diff --git a/__init__.py b/fuse/__init__.py
index 4f327c1..75f61d0 100644
--- a/__init__.py
+++ b/fuse/__init__.py
@@ -1,3 +1,5 @@
+__version__ = '1.2'
+
import sys
pyver = sys.version_info[0:2]
if pyver <= (2, 4):
diff --git a/fuse.py b/fuse/fuse.py
index e4e4c0e..a921c25 100644
--- a/fuse.py
+++ b/fuse/fuse.py
@@ -25,8 +25,6 @@ from stat import S_IFDIR
from traceback import print_exc
-__version__ = '1.1'
-
_system = system()
_machine = machine()
diff --git a/fuse24.py b/fuse/fuse24.py
index 8c20679..8c20679 100644
--- a/fuse24.py
+++ b/fuse/fuse24.py
diff --git a/fuse3.py b/fuse/fuse3.py
index 8717b47..8717b47 100644
--- a/fuse3.py
+++ b/fuse/fuse3.py
diff --git a/setup.py b/setup.py
index 0a8b7a4..4f1bc5e 100755
--- a/setup.py
+++ b/setup.py
@@ -1,17 +1,17 @@
#!/usr/bin/env python
-from setuptools import setup
-
-import fuse
+from setuptools import setup, find_packages
+from fuse import __version__
setup(
- name='fusepy',
- version=fuse.__version__,
- description='Simple ctypes bindings for FUSE',
- author='Giorgos Verigakis',
- author_email='verigak@gmail.com',
- url='http://code.google.com/p/fusepy/',
- license='ISC',
- py_modules=['fuse']
+ name = 'fusepy',
+ version = __version__,
+ packages = find_packages(),
+
+ description = 'Simple ctypes bindings for FUSE',
+ author = 'Giorgos Verigakis',
+ author_email = 'verigak@gmail.com',
+ url = 'http://code.google.com/p/fusepy/',
+ license = 'ISC',
)