summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNejc Habjan <nejc.habjan@siemens.com>2023-04-07 11:00:41 +0200
committerJohn Villalovos <john@sodarock.com>2023-04-07 08:16:10 -0700
commit3abc55727d4d52307b9ce646fee172f94f7baf8d (patch)
tree747a11441230affc6830dab7de914ae90d998a93 /setup.py
parent3057f459765d1482986f2086beb9227acc7fd15f (diff)
downloadgitlab-3abc55727d4d52307b9ce646fee172f94f7baf8d.tar.gz
chore(setup): depend on typing-extensions for 3.7 until EOL
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f02b05f..80e396c 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,11 @@ setup(
license="LGPL-3.0-or-later",
url="https://github.com/python-gitlab/python-gitlab",
packages=find_packages(exclude=["docs*", "tests*"]),
- install_requires=["requests>=2.25.0", "requests-toolbelt>=0.10.1"],
+ install_requires=[
+ "requests>=2.25.0",
+ "requests-toolbelt>=0.10.1",
+ "typing-extensions>=4.0.0;python_version<'3.8'",
+ ],
package_data={
"gitlab": ["py.typed"],
},