summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMax Wittig <max.wittig95@gmail.com>2018-12-09 10:42:16 +0100
committerMax Wittig <max.wittig@siemens.com>2018-12-09 10:44:24 +0100
commit6898097c45d53a3176882a3d9cb86c0015f8d491 (patch)
treea49434edda49d2d0f46805d337fd558702f7411b /setup.py
parent704ca51d9e487b2a665f219a5f7ce8b05e8eeea7 (diff)
downloadgitlab-6898097c45d53a3176882a3d9cb86c0015f8d491.tar.gz
docs(setup): use proper readme on PyPI
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 02773eb..b592e7c 100644
--- a/setup.py
+++ b/setup.py
@@ -11,11 +11,13 @@ def get_version():
if line.startswith('__version__'):
return eval(line.split('=')[-1])
+with open("README.rst", "r") as readme_file:
+ readme = readme_file.read()
setup(name='python-gitlab',
version=get_version(),
description='Interact with GitLab API',
- long_description='Interact with GitLab API',
+ long_description=readme,
author='Gauvain Pocentek',
author_email='gauvain@pocentek.net',
license='LGPLv3',