diff options
author | Gauvain Pocentek <gauvain.pocentek@objectif-libre.com> | 2016-02-03 20:32:29 +0100 |
---|---|---|
committer | Gauvain Pocentek <gauvain.pocentek@objectif-libre.com> | 2016-02-03 20:32:29 +0100 |
commit | 9ae26fe859e11bdc86f8662b6cca34522946dadf (patch) | |
tree | a4b1db9f0c6704453544f12165f48899d0f58fb4 /setup.py | |
parent | 8642e9eec44ab6b9d00581a6d5b53e8d719abec7 (diff) | |
download | gitlab-9ae26fe859e11bdc86f8662b6cca34522946dadf.tar.gz |
Partially revert 00ab7d00
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 10 |
1 files changed, 8 insertions, 2 deletions
@@ -3,11 +3,17 @@ from setuptools import setup from setuptools import find_packages -import gitlab.version + + +def get_version(): + with open('gitlab/__init__.py') as f: + for line in f: + if line.startswith('__version__'): + return eval(line.split('=')[-1]) setup(name='python-gitlab', - version=gitlab.version.version, + version=get_version(), description='Interact with GitLab API', long_description='Interact with GitLab API', author='Gauvain Pocentek', |