diff options
author | John L. Villalovos <john@sodarock.com> | 2022-01-15 08:31:00 -0800 |
---|---|---|
committer | John L. Villalovos <john@sodarock.com> | 2022-01-15 08:31:00 -0800 |
commit | b981ce7fed88c5d86a3fffc4ee3f99be0b958c1d (patch) | |
tree | 9e8e41154f80a3408972cece6fc4328c8186e455 /setup.py | |
parent | cbbe7ce61db0649be286c5c1a239e00ed86f8039 (diff) | |
download | gitlab-b981ce7fed88c5d86a3fffc4ee3f99be0b958c1d.tar.gz |
chore: rename `gitlab/__version__.py` -> `gitlab/_version.py`jlvillal/version_mv
It is confusing to have a `gitlab/__version__.py` because we also
create a variable `gitlab.__version__` which can conflict with
`gitlab/__version__.py`.
For example in `gitlab/const.py` we have to know that
`gitlab.__version__` is a module and not the variable due to the
ordering of imports. But in most other usage `gitlab.__version__` is a
version string.
To reduce confusion make the name of the version file
`gitlab/_version.py`.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -6,7 +6,7 @@ from setuptools import find_packages, setup def get_version() -> str: version = "" - with open("gitlab/__version__.py") as f: + with open("gitlab/_version.py") as f: for line in f: if line.startswith("__version__"): version = eval(line.split("=")[-1]) |