diff options
author | Nejc Habjan <nejc.habjan@siemens.com> | 2022-01-23 10:04:31 +0100 |
---|---|---|
committer | John Villalovos <john@sodarock.com> | 2022-01-23 07:14:49 -0800 |
commit | dc32d54c49ccc58c01cd436346a3fbfd4a538778 (patch) | |
tree | dfce87b5e50f49229bd3ff5d62c2d26618046409 /setup.py | |
parent | 618267ced7aaff46d8e03057fa0cab48727e5dc0 (diff) | |
download | gitlab-dc32d54c49ccc58c01cd436346a3fbfd4a538778.tar.gz |
chore: consistently use open() encoding and file descriptor
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -6,7 +6,7 @@ from setuptools import find_packages, setup def get_version() -> str: version = "" - with open("gitlab/_version.py") as f: + with open("gitlab/_version.py", "r", encoding="utf-8") as f: for line in f: if line.startswith("__version__"): version = eval(line.split("=")[-1]) @@ -14,8 +14,8 @@ def get_version() -> str: return version -with open("README.rst", "r") as readme_file: - readme = readme_file.read() +with open("README.rst", "r", encoding="utf-8") as f: + readme = f.read() setup( name="python-gitlab", |