summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMichael Shields <mshields@google.com>2008-09-24 22:09:23 +0000
committerMichael Shields <mshields@google.com>2008-09-24 22:09:23 +0000
commit23f96037ec7972f59dd82fac8e2336baf48eeb87 (patch)
treeb5a8ec2af63b3c48b9ee048267736f715eac82ad /setup.py
parenta40f254fca3ab49da68eb0deb7a608cfd21e79c4 (diff)
downloadipaddr-py-23f96037ec7972f59dd82fac8e2336baf48eeb87.tar.gz
Initial open source release, version 1.0.0.
git-svn-id: https://ipaddr-py.googlecode.com/svn/trunk@2 09200d28-7f98-11dd-ad27-0f66e57d2035
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py35
1 files changed, 35 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6088ced
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,35 @@
+#!/usr/bin/python
+#
+# Copyright 2008 Google Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from distutils.core import setup
+
+import ipaddr
+
+
+setup(name='ipaddr',
+ maintainer='Google',
+ maintainer_email='ipaddr-py-dev@googlegroups.com',
+ version=ipaddr.__version__,
+ url='http://code.google.com/p/ipaddr-py/',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Networking'],
+ py_modules=['ipaddr'])