summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
Diffstat (limited to 'docs')
-rw-r--r--docs/index.rst5
-rw-r--r--docs/install.rst10
2 files changed, 7 insertions, 8 deletions
diff --git a/docs/index.rst b/docs/index.rst
index 2f54b09..fd13a46 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -101,8 +101,9 @@ Compression
***********
kafka-python supports gzip compression/decompression natively. To produce or
-consume snappy and lz4 compressed messages, you must install lz4 (lz4-cffi
-if using pypy) and/or python-snappy (also requires snappy library).
+consume lz4 compressed messages, you must install lz4tools and xxhash (modules
+may not work on python2.6). To enable snappy, install python-snappy (also
+requires snappy library).
See `Installation <install.html#optional-snappy-install>`_ for more information.
diff --git a/docs/install.rst b/docs/install.rst
index aba5019..4dca5d0 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -40,14 +40,12 @@ Using `setup.py` directly:
Optional LZ4 install
********************
-To enable LZ4 compression/decompression, install `lz4`:
+To enable LZ4 compression/decompression, install lz4tools and xxhash:
->>> pip install lz4
-
-Or `lz4-cffi` if using pypy:
-
->>> pip install lz4-cffi
+>>> pip install lz4tools
+>>> pip install xxhash
+*Note*: these modules do not support python2.6
Optional Snappy install
***********************