summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorInada Naoki <songofacandy@gmail.com>2020-12-11 19:31:24 +0900
committerInada Naoki <songofacandy@gmail.com>2020-12-11 19:31:24 +0900
commitedd56036616e5f7211d5cd840a4d00bb43a7f9ee (patch)
tree1e499d4de37894a5a329be84be2668a9eaad91f6
parentd893697eab07a2cf2a02f5115d4e7bae99d07e3f (diff)
downloadmsgpack-python-edd56036616e5f7211d5cd840a4d00bb43a7f9ee.tar.gz
Actions: Add Python 3.9
-rw-r--r--.github/workflows/linux.yml11
-rw-r--r--.github/workflows/mac.yml17
-rw-r--r--.github/workflows/windows.yaml14
3 files changed, 42 insertions, 0 deletions
diff --git a/.github/workflows/linux.yml b/.github/workflows/linux.yml
index 50a0abe..f9707b1 100644
--- a/.github/workflows/linux.yml
+++ b/.github/workflows/linux.yml
@@ -47,6 +47,17 @@ jobs:
pytest -v test
+ - name: Set up Python 3.9
+ uses: actions/setup-python@v1
+ with:
+ python-version: 3.9
+
+ - name: Run test (3.9)
+ run: |
+ pip install pytest
+ pip install -v msgpack --only-binary :all: --no-index -f dist/wheelhouse
+ pytest -v test
+
- name: Set up Python 3.7
uses: actions/setup-python@v1
with:
diff --git a/.github/workflows/mac.yml b/.github/workflows/mac.yml
index fb2c67f..78d944c 100644
--- a/.github/workflows/mac.yml
+++ b/.github/workflows/mac.yml
@@ -35,6 +35,23 @@ jobs:
pytest -v test
+ - name: Set up Python 3.9
+ uses: actions/setup-python@v1
+ with:
+ python-version: "3.9"
+
+ - name: Build wheel
+ run: |
+ pip install setuptools wheel
+ python setup.py bdist_wheel
+
+ - name: Run test
+ run: |
+ pip install pytest
+ pip install -v msgpack --only-binary :all: -f dist/ --no-index
+ pytest -v test
+
+
- name: Set up Python 3.7
uses: actions/setup-python@v1
with:
diff --git a/.github/workflows/windows.yaml b/.github/workflows/windows.yaml
index cecb825..139a5a6 100644
--- a/.github/workflows/windows.yaml
+++ b/.github/workflows/windows.yaml
@@ -63,6 +63,20 @@ jobs:
run: |
ci/runtests.sh
+ - name: Python 3.9 (amd64)
+ env:
+ PYTHON: "py -3.9-64"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
+ - name: Python 3.9 (x86)
+ env:
+ PYTHON: "py -3.9-32"
+ shell: bash
+ run: |
+ ci/runtests.sh
+
- name: Upload Wheels
uses: actions/upload-artifact@v1
with: